re = /text/m
str = 'TEXT text mytext lotsotexts texttexttext so much text!
The text can even be found on the second text-line.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end