$re = '/text/m';
$str = 'TEXT text mytext lotsotexts texttexttext so much text!
The text can even be found on the second text-line.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);