package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)text`)
var str = `TEXT text mytext lotsotexts texttexttext so much text!
The text can even be found on the second text-line.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}