const regex = /(?P<reference_sequence>(NP|XP|WP)_[0-9]{4,12})\.(?P<version>([0-9]?[0-9])):(?P<prefix>p)\.(?P<ref>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)(?P<start>[1-9][0-9]{0,7})(?P<alt>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)+fs(Ter[1-9][0-9]{0,7}|\*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<reference_sequence>(NP|XP|WP)_[0-9]{4,12})\\.(?P<version>([0-9]?[0-9])):(?P<prefix>p)\\.(?P<ref>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)(?P<start>[1-9][0-9]{0,7})(?P<alt>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)+fs(Ter[1-9][0-9]{0,7}|\\*)$', 'gm')
const str = `NP_001230111.1:p.Arg97ProfsTer12
NP_001230111.1:p.Arg97Profs*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}