$re = '/(?P<reference_sequence>(NP|XP|WP)_[0-9]{4,12})\.(?P<version>([0-9]?[0-9])):(?P<prefix>p)\.(?P<ref>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)(?P<start>[1-9][0-9]{0,7})(?P<alt>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)+fs(Ter[1-9][0-9]{0,7}|\*)$/m';
$str = 'NP_001230111.1:p.Arg97ProfsTer12
NP_001230111.1:p.Arg97Profs*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);