# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[A-Z]([A-Z](?![a-z]))*/_$0/gm;t' <<< "CamelCaseForTheWin
ACar
BuyACar
XML
SimpleXML"