#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[A-Z]([A-Z](?![a-z]))*"
Local $sString = "CamelCaseForTheWin" & @CRLF & _
"ACar" & @CRLF & _
"BuyACar" & @CRLF & _
"XML" & @CRLF & _
"SimpleXML"
Local $sSubst = "_$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)