$re = '/[A-Z]([A-Z](?![a-z]))*/m';
$str = 'CamelCaseForTheWin
ACar
BuyACar
XML
SimpleXML';
$subst = "_$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;