using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bMVC(0*[1-9][0-9]?|1[0-8][0-9]|19[0-6])\b";
string input = @"MVC123 MVC034 MVC001 MVC196
MVC197 MVC000 MVC876";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}