import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMVC(0*[1-9][0-9]?|1[0-8][0-9]|19[0-6])\\b";
final String string = "MVC123 MVC034 MVC001 MVC196\n"
+ "MVC197 MVC000 MVC876";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}