import re
regex = re.compile(r"\bMVC(0*[1-9][0-9]?|1[0-8][0-9]|19[0-6])\b")
test_str = ("MVC123 MVC034 MVC001 MVC196\n"
"MVC197 MVC000 MVC876")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")