re = /\bMVC(0*[1-9][0-9]?|1[0-8][0-9]|19[0-6])\b/
str = 'MVC123 MVC034 MVC001 MVC196
MVC197 MVC000 MVC876'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end