import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<tabledata>\\S+)\\s+\\S+(?<vals>[|\\d\\s]+)";
final String string = "TABLE1\n"
+ "=======\n"
+ "1 | 2\n"
+ "15 | 2\n"
+ "3 | 15\n\n"
+ "TABLE2\n"
+ "=======\n"
+ "3 | 5\n"
+ "12 | 2\n"
+ "17 | 7";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}