re = /(?<tabledata>\S+)\s+\S+(?<vals>[|\d\s]+)/
str = 'TABLE1
=======
1 | 2
15 | 2
3 | 15
TABLE2
=======
3 | 5
12 | 2
17 | 7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end