$re = '/(?<tabledata>\S+)\s+\S+(?<vals>[|\d\s]+)/';
$str = 'TABLE1
=======
1 | 2
15 | 2
3 | 15
TABLE2
=======
3 | 5
12 | 2
17 | 7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);