import re
regex = re.compile(r"(?<tabledata>\S+)\s+\S+(?<vals>[|\d\s]+)")
test_str = ("TABLE1\n"
"=======\n"
"1 | 2\n"
"15 | 2\n"
"3 | 15\n\n"
"TABLE2\n"
"=======\n"
"3 | 5\n"
"12 | 2\n"
"17 | 7")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")