import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*\\\\)?(?:.+\\.)?(.+)(?<!\\.min)(?:(\\.min)?\\.js)$";
final String string = "kendo.culture.ne-NP.min.js\n"
+ "kendo.culture.ne-NP.js\n"
+ "kendo.culture.ne.min.js\n"
+ "kendo.culture.ne.js\n"
+ "c:\\kendo.culture.ne-NP.min.js\n"
+ "c:\\kendo.culture.ne-NP.js\n"
+ "ne.js\n"
+ "ne-NP.js\n"
+ "c:\\ne.js\n"
+ "c:\\ne-NP.js\n"
+ "ne.min.js\n"
+ "ne-NP.min.js\n"
+ "c:\\ne.min.js\n"
+ "c:\\ne-NP.min.js\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}