const regex = /^(?:.*\\)?(?:.+\.)?(.+)(?<!\.min)(?:(\.min)?\.js)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*\\\\)?(?:.+\\.)?(.+)(?<!\\.min)(?:(\\.min)?\\.js)$', 'gm')
const str = `kendo.culture.ne-NP.min.js
kendo.culture.ne-NP.js
kendo.culture.ne.min.js
kendo.culture.ne.js
c:\\kendo.culture.ne-NP.min.js
c:\\kendo.culture.ne-NP.js
ne.js
ne-NP.js
c:\\ne.js
c:\\ne-NP.js
ne.min.js
ne-NP.min.js
c:\\ne.min.js
c:\\ne-NP.min.js
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}