import re
regex = re.compile(r"^(?:.*\\)?(?:.+\.)?(.+)(?<!\.min)(?:(\.min)?\.js)$", flags=re.MULTILINE)
test_str = ("kendo.culture.ne-NP.min.js\n"
"kendo.culture.ne-NP.js\n"
"kendo.culture.ne.min.js\n"
"kendo.culture.ne.js\n"
"c:\\kendo.culture.ne-NP.min.js\n"
"c:\\kendo.culture.ne-NP.js\n"
"ne.js\n"
"ne-NP.js\n"
"c:\\ne.js\n"
"c:\\ne-NP.js\n"
"ne.min.js\n"
"ne-NP.min.js\n"
"c:\\ne.min.js\n"
"c:\\ne-NP.min.js\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")