use strict;
my $str = 'kendo.culture.ne-NP.min.js
kendo.culture.ne-NP.js
kendo.culture.ne.min.js
kendo.culture.ne.js
c:\\kendo.culture.ne-NP.min.js
c:\\kendo.culture.ne-NP.js
ne.js
ne-NP.js
c:\\ne.js
c:\\ne-NP.js
ne.min.js
ne-NP.min.js
c:\\ne.min.js
c:\\ne-NP.min.js
';
my $regex = qr/^(?:.*\\)?(?:.+\.)?(.+)(?<!\.min)(?:(\.min)?\.js)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}