#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*y)([^y]*)(?=x(?=[^x]*y))"
Local $sString = "abxabxaby -> abxab" & @CRLF & _
"12xabcyabcxay -> 12" & @CRLF & _
"abcxy -> abc" & @CRLF & _
"abcx" & @CRLF & _
"abcy" & @CRLF & _
"abcyx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")