using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*y)([^y]*)(?=x(?=[^x]*y))";
string input = @"abxabxaby -> abxab
12xabcyabcxay -> 12
abcxy -> abc
abcx
abcy
abcyx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}