re = /^(?=.*y)([^y]*)(?=x(?=[^x]*y))/m
str = 'abxabxaby -> abxab
12xabcyabcxay -> 12
abcxy -> abc
abcx
abcy
abcyx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end