$re = '/^(?=.*y)([^y]*)(?=x(?=[^x]*y))/m';
$str = 'abxabxaby -> abxab
12xabcyabcxay -> 12
abcxy -> abc
abcx
abcy
abcyx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);