using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p class=""TEXT"">(?:(?!<br>).)*$";
string input = @"<p class=""TEST"">My mother is at home.<br>
<p class=""TEST"">My father is at home.<br>
<p class=""TEXT"">My sister is at home.<LLbr>
<p class=""TEXT"">My brother is at home.<AAbr>
<p class=""TEXT"">NEW SCENARIO.
<br>
Toto's regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}