import re
regex = re.compile(r"<p class=\"TEXT\">(?:(?!<br>).)*$", flags=re.MULTILINE)
test_str = ("<p class=\"TEST\">My mother is at home.<br>\n"
"<p class=\"TEST\">My father is at home.<br>\n"
"<p class=\"TEXT\">My sister is at home.<LLbr>\n"
"<p class=\"TEXT\">My brother is at home.<AAbr>\n\n"
"<p class=\"TEXT\">NEW SCENARIO.\n"
"<br>\n\n"
"Toto's regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")