import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p class=\"TEXT\">(?:(?!<br>)(?!<p).)*(?:<.+?>|\\z)";
final String string = "<p class=\"TEST\">My mother is at home.<br>\n"
+ "<p class=\"TEST\">My father is at home.<br>\n"
+ "<p class=\"TEXT\">My sister is at home.<LLbr>\n"
+ "<p class=\"TEXT\">My brother is at home.<AAbr>\n\n"
+ "<p class=\"TEXT\">NEW SCENARIO.\n"
+ "<br>\n\n"
+ "Toto's regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}