const regex = /<p class="TEXT">(?:(?!<br>)(?!<p).)*(?:<.+?>|\z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p class="TEXT">(?:(?!<br>)(?!<p).)*(?:<.+?>|\\z)', 'gm')
const str = `<p class="TEST">My mother is at home.<br>
<p class="TEST">My father is at home.<br>
<p class="TEXT">My sister is at home.<LLbr>
<p class="TEXT">My brother is at home.<AAbr>
<p class="TEXT">NEW SCENARIO.
<br>
Toto's regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}