re = /<p class="TEXT">(?:(?!<br>)(?!<p).)*(?:<.+?>|\z)/m
str = '<p class="TEST">My mother is at home.<br>
<p class="TEST">My father is at home.<br>
<p class="TEXT">My sister is at home.<LLbr>
<p class="TEXT">My brother is at home.<AAbr>
<p class="TEXT">NEW SCENARIO.
<br>
Toto\'s regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end