# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<p class=\"TEXT\">(?:(?!<br>)(?!<p).)*(?:<.+?>|\z)"
test_str = ("<p class=\"TEST\">My mother is at home.<br>\n"
"<p class=\"TEST\">My father is at home.<br>\n"
"<p class=\"TEXT\">My sister is at home.<LLbr>\n"
"<p class=\"TEXT\">My brother is at home.<AAbr>\n\n"
"<p class=\"TEXT\">NEW SCENARIO.\n"
"<br>\n\n"
"Toto's regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.