import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9][' ']{7,7}";
final String string = "1 KB4021558\n"
+ "2 KB4021915\n"
+ "2 KB4022747\n"
+ "2 KB4022884\n"
+ "2 KB4022887\n"
+ "2 KB4024323\n"
+ "2 KB4024402\n"
+ "3 KB3203427\n"
+ "3 KB3203484\n"
+ "4 KB3127894\n"
+ "4 KB3191828\n"
+ "4 KB3203436\n"
+ "4 KB3203438\n"
+ "5 KB4014580\n"
+ "6 KB2756918\n"
+ "7 KB4014570";
final String subst = " CALL ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}