// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9][' ']{7,7}").unwrap();
let string = "1 KB4021558
2 KB4021915
2 KB4022747
2 KB4022884
2 KB4022887
2 KB4024323
2 KB4024402
3 KB3203427
3 KB3203484
4 KB3127894
4 KB3191828
4 KB3203436
4 KB3203438
5 KB4014580
6 KB2756918
7 KB4014570";
let substitution = " CALL ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}