const regex = /^[0-9][' ']{7,7}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9][\' \']{7,7}', 'gm')
const str = `1 KB4021558
2 KB4021915
2 KB4022747
2 KB4022884
2 KB4022887
2 KB4024323
2 KB4024402
3 KB3203427
3 KB3203484
4 KB3127894
4 KB3191828
4 KB3203436
4 KB3203438
5 KB4014580
6 KB2756918
7 KB4014570`;
const subst = ` CALL `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);