#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{2})\s+(.+)\s+(\d{3})\s+(.+)"
Local $sString = "01" & @CRLF & _
"ALABAMA" & @CRLF & _
"001" & @CRLF & _
"AUTAUGA" & @CRLF & _
"61" & @CRLF & _
"ATLANTIC COAST OFFSHORE" & @CRLF & _
"177" & @CRLF & _
"NF 17-2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")