using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2})\s+(.+)\s+(\d{3})\s+(.+)";
string input = @"01
ALABAMA
001
AUTAUGA
61
ATLANTIC COAST OFFSHORE
177
NF 17-2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}