re = /(\d{2})\s+(.+)\s+(\d{3})\s+(.+)/
str = '01
ALABAMA
001
AUTAUGA
61
ATLANTIC COAST OFFSHORE
177
NF 17-2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end