import re
regex = re.compile(r"(\d{2})\s+(.+)\s+(\d{3})\s+(.+)")
test_str = ("01\n"
"ALABAMA\n"
"001\n"
"AUTAUGA\n"
"61\n"
"ATLANTIC COAST OFFSHORE\n"
"177\n"
"NF 17-2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")