#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){(if '?{?)?(.*?)_en-us(.*?)}"
Local $sString = "{exp:channel:entries channel="" url_title="doors" limit="1"}" & @CRLF & _
"" & @CRLF & _
"{exp:playa:children field="video_slider" var_prefix="videoslider"}" & @CRLF & _
" {if {videoslider:total_results} != '0'}" & @CRLF & _
" {if {videoslider:count}=='1'}" & @CRLF & _
" {if '{video_slider_title_en-us}'!='NULL'}" & @CRLF & _
" {video_slider_title_en-us}" & @CRLF & _
" {if:else}" & @CRLF & _
" Videos" & @CRLF & _
" {/if}" & @CRLF & _
" {/if}" & @CRLF & _
" {if video_thumb != ''}" & @CRLF & _
" {if:else}" & @CRLF & _
" {exp:url_tube:thumbnail src="{videoslider:video_file}" width="334" height="150"}" & @CRLF & _
" {/if}" & @CRLF & _
" {if video_thumb_title != ''}" & @CRLF & _
" {video_thumb_title}" & @CRLF & _
" {if:else}" & @CRLF & _
" {videoslider:title}" & @CRLF & _
" {/if}" & @CRLF & _
" {if {videoslider:count}=={videoslider:total_results}}" & @CRLF & _
" {/if}" & @CRLF & _
"{/exp:playa:children}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{/exp:channel:entries}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")