$re = '/{(if \'?{?)?(.*?)_en-us(.*?)}/m';
$str = '{exp:channel:entries channel="" url_title="doors" limit="1"}
{exp:playa:children field="video_slider" var_prefix="videoslider"}
{if {videoslider:total_results} != \'0\'}
{if {videoslider:count}==\'1\'}
{if \'{video_slider_title_en-us}\'!=\'NULL\'}
{video_slider_title_en-us}
{if:else}
Videos
{/if}
{/if}
{if video_thumb != \'\'}
{if:else}
{exp:url_tube:thumbnail src="{videoslider:video_file}" width="334" height="150"}
{/if}
{if video_thumb_title != \'\'}
{video_thumb_title}
{if:else}
{videoslider:title}
{/if}
{if {videoslider:count}=={videoslider:total_results}}
{/if}
{/exp:playa:children}
{/exp:channel:entries}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);