use strict;
my $str = 'begravningsplatser/1656
begravningsplatser/ABD
begravningsplatser/16562222
156260
Error156260
3459?pid=1
3459?pid=AAAA
3459?pid=12020
3459?pid=12020B';
my $regex = qr/\d+\?pid=\d+|begravningsplatser\/\d{1,4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}