re = /\d+\?pid=\d+|begravningsplatser\/\d{1,4}/m
str = 'begravningsplatser/1656
begravningsplatser/ABD
begravningsplatser/16562222
156260
Error156260
3459?pid=1
3459?pid=AAAA
3459?pid=12020
3459?pid=12020B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end