import re
regex = re.compile(r"\d+\?pid=\d+|begravningsplatser\/\d{1,4}", flags=re.MULTILINE)
test_str = ("begravningsplatser/1656\n"
"begravningsplatser/ABD\n"
"begravningsplatser/16562222\n"
"156260\n"
"Error156260\n"
"3459?pid=1\n"
"3459?pid=AAAA\n"
"3459?pid=12020\n"
"3459?pid=12020B")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")