$re = '/\d+\?pid=\d+|begravningsplatser\/\d{1,4}/m';
$str = 'begravningsplatser/1656
begravningsplatser/ABD
begravningsplatser/16562222
156260
Error156260
3459?pid=1
3459?pid=AAAA
3459?pid=12020
3459?pid=12020B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);