const regex = /(?:=)(\d{5})(?:[&|\n])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:=)(\\d{5})(?:[&|\\n])', 'g')
const str = `key1=12345
key1=12345&key2=12345
key1=12345123456789
key1=12345123456789&key2=123456789
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}