re = /(?:=)(\d{5})(?:[&|\n])/
str = 'key1=12345
key1=12345&key2=12345
key1=12345123456789
key1=12345123456789&key2=123456789
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end