$re = '/(?:=)(\d{5})(?:[&|\n])/';
$str = 'key1=12345
key1=12345&key2=12345
key1=12345123456789
key1=12345123456789&key2=123456789
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);