// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:=)(\d{5})(?:[&|\n])").unwrap();
let string = "key1=12345
key1=12345&key2=12345
key1=12345123456789
key1=12345123456789&key2=123456789
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}