package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^(([0-1]?\d{1,2})|(2[0-5]{2}))(\.(([0-1]?\d{1,2})|(2[0-5]{2}))){3}$)`)
var str = `194.115.1.4
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}