import re
regex = re.compile(r"(^(([0-1]?\d{1,2})|(2[0-5]{2}))(\.(([0-1]?\d{1,2})|(2[0-5]{2}))){3}$)")
test_str = ("194.115.1.4\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")