const regex = new RegExp('(^(([0-1]?\\d{1,2})|(2[0-5]{2}))(\\.(([0-1]?\\d{1,2})|(2[0-5]{2}))){3}$)', '')
const str = `194.115.1.4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}